
Review For Windows  
The following is a list of help topics available.
Using Help 
About... 
Add CC 
Automatic Deferrals File 
Auto-deferrals 
Buttons 
Comment 
Comment Number 
Setup 
Connect To Host 
Context Sensitive Help 
Deferrals File 
Defer All Items 
Defer/Undefer All Commands 
Defer/Undefer Item 
Delete All Items 
Delete CC 
Delete CIS Message 
Delete Item 
Double Post Check 
Edit CC 
Edit CC's 
Edit Item 
Edit Script File 
Editor 
Exit on connection 
Exit Review 
Fcomment 
Free Disk Space 
History 
History File 
Mail 
Main File 
Prune History File 
Quiet connection 
Remove Duplicate Commands 
Reply 
Restore Original Files 
Return To Script 
Say 
Show All Titles 
Show Title 
Selecting Script Files 
Thread 
Time Out 
Tool Bar 
Undefer All Items 
View Item 
View Original 
View Script File 



Script Commands  
The following is a list of user defined script commands.
Show 
Mailful 
Rjoin 
Maildel 
Rresign 
Fdl 
Rshow 
Rresume 
Withdraw 
Ful 
Getresume 
Putresume 
Getprofile 
Putprofile 
Fdir 
Getflist 
Putflist 
Binmail 
Maildir 
Mailfdl 
Mailera 
Flist 
Restore 
Scputdown 
Fal 
Mailren 
Export 
Clearmail 
Mailunread 
Absence 
Copy 
Ffind 
Rsquick 
Rsearch 
Rfind 
Messages 
Scputup 
Modera 
Modren 
Fexport 
Usenet 
Urjoin 
Urresign 
Billing 



Using Help  
For help on using Help use the F1 key or Alt-H and select the first item in the Help menu.



About Review  

 
To get Review version information, pick the 'About...' option from the Help menu.
You will be shown the version number of Review, whether it's a BETA version, and finally 
who helped write it.



Add CC  
This option will allow you to add a mail message recipient.
When editing cc's, press <Ctrl-A> or press the 'Add button. A dialog box will appear and 
you can enter the name of the recipient.



Automatic Deferrals File  
The automatic deferrals file is used to store user commands deferred automatically by 
Review during peak and standard rate connections. Only commands in this file will be 
automatically undeferred for cheap rate connections.
To switch to the automatic deferrals file, press <M> or select autoMatic deferrals file 
from the File menu.
To set up automatic deferrals, refer to WREVIEW.TXT.
Defer/Undefer Item 
Selecting Script Files 



Auto-deferrals  

 
Allows the user to define which commands are to be automatically deferred.
Defer/Undefer Item 
Selecting Script Files 



Buttons  
Review's push buttons can be activated by clicking on them with the mouse. The active 
button is always highlighted and pressing enter will perform the action associated with 
the active button.
If you don't have a mouse, you can use the left and right cursor keys (or tab and shift-
tab) to select the appropriate button and press enter to perform the action selected.
The active key for each button is highlighted and, as an alternative, you can press this 
key to select the button.
Use the mouse or keyboard as described above to select one of the buttons shown below
to get Help relating to the button selected.

 



Comment  
A comment is denoted by a 'com' or 'c' at the start of the second column of Review's 
script file list. This is followed by the number of the message being commented to and 
part of the first line of your comment. The first column shows the conference/topic where
your comment will be posted.
You can perform a variety of operations on a comment by highlighting it and selecting 
the required operation from the Item menu (or pressing the appropriate hot-key).
Edit Item 
View Item 
Delete Item 
Defer/Undefer Item 
Comment Number 
View Original 
Fcomment 



Comment Number  
You can change the number of the message being commented to by highlighting the 
comment and selecting this option (by pressing <N> or by picking 'comment Number' 
from the Item menu).
You will be presented with the number of the message you are currently commenting to 
in a dialog box. You may edit the number and press enter or pick the OK button to save 
the change. You can press escape or pick the Cancel button to abort the change.
Comment 
View Original 
Fcomment 



Setup  

 
This option will let you modify some aspects of Review's configuration from within 
Review. Other items can only be changed during installation or by editing the Review 
configuration file manually.
Select this option by picking Setup from the Options menu.
Editor 
Exit on Connect 
History File 
Quiet Connection 
Time Out 
Toolbar 



Connect To Host  
This option will terminate the Review session and connect you to the host. You can only 
do this if Review was invoked as part of the connection process and you are currently 
reviewing the main script file.
To select this option, highlight 'Connect to host' in the main script file and press enter or 
pick coNnect to host from the File menu.
If your main script file contains any duplicate commands, Review will not let you make 
the connection until the problem has been put right.
Exit Review 
Remove Duplicate Commands 
Selecting Script Files 



Context Sensitive Help  
To get context sensitive Help for a highlighted menu item press F1.
To get context sensitive Help for a region of the screen press Shift-F1 and select the 
region.
Using Help 



Deferrals File  
The deferrals file can be used to store messages and commands that you want to post 
later.
To switch to the deferrals file, press <S> or select Switch to deferrals file from the File 
menu.
You can perform the normal Review functions on all items in the deferrals file.
Defer/Undefer Item 
Defer All Items 
Undefer All Items 
Selecting Script Files 



Defer All Items  
This option will defer all items in the main script file. Each item will be transferred to the 
deferrals file and can be retrieved later.
To select this option, press Alt-D or pick Defer all items from the File menu.
Defer/Undefer Item 
Undefer All Items 
Defer/Undefer All Commands 
Selecting Script Files 



Defer/Undefer All Commands  
This option will defer or undefer all commands in the current script file. If you are 
reviewing the main script file, commands will be transferred to the deferrals file. If you 
are reviewing the deferrals file, commands will be transferred to main script file.
To select this option, press <A> or pick defer/undefer All cmds from the File menu.
Defer/Undefer All Commands 
Defer All Items 
Undefer All Items 



Defer/Undefer Item  
This option will defer or undefer the highlighted script item. If you are reviewing the main
script file, the item will be transferred to the deferrals file. If you are reviewing the 
deferrals file, the item will be transferred back to the main script file.
To defer an item, highlight it and press <D> or pick Defer/undefer from the Item menu. 
To undefer an item, highlight it and press <U> or pick Defer/undefer from the Item menu.
Defer All Items 
Undefer All Items 
Defer/Undefer All Commands 



Delete All Items  
This option will delete all items in the current script file (main, deferrals, automatic 
deferrals or history). You will be asked for confirmation before any action is taken.
To select this option, press Alt-Delete or pick deLete all items from the File menu.
Delete Item 
Remove Duplicate Commands 
Defer/Undefer Item 
Restore Original Files 



Delete CC  
This option will allow you to delete a mail message recipient (only cc's).
When editing cc's, press <Alt_D> or press the Delete button.
Edit CC's 



Delete CIS Message  
This type of script item only applies to CompuServe and is denoted by a 'd' at the start of
the second column of Review's script file list. This is followed by the number of the 
message to be deleted and part of the first line of that message. The first column shows 
the forum containing the message to be deleted.
You can perform a variety of operations on this type of item by highlighting it and 
selecting the required operation from the Item menu (or pressing the appropriate hot-
key).
View Item 
Delete Item 
Defer/Undefer Item 



Delete Item  
This option will delete the highlighted item from the script file altogether.
To delete an item from the script file, highlight it and press delete or pick deLete from the
Item menu. 
Defer/Undefer Item 
Delete All Items 
Restore Original Files 



Double Post Check  
This option will check your WW message base to see whether it already contains 
messages in the current script file. This is most likely to be useful in conjunction with the 
history file when a connection has failed for some reason. In this case, the best thing do 
is to delete all messages in the main script file and connect again in order to make sure 
your WW message base is up to date. If you are connecting to CIX, the CIX restore 
command or the WW reconstruct command may be of use.
Now switch to the history file and get Review to scan for duplicates. To do this, press 
<B> or pick double post check from the File menu. Review will prompt you for a date to 
scan from. Review will now scan the topic message files and report matches. 
You can now use the results of the search to decide which messages to undefer back to 
the main script file. 
History File 
Selecting Script Files 



Edit CC  
This option will allow you to edit a mail message recipient.
When editing cc's, press <cr> or pick Edit cc from the Action menu. A dialog box 
containing the highlighted recipient will appear and you can make any changes required.
Edit CC's 



Edit CC's  

 
This option will allow you to edit the recipients of the mail message highlighted.
Press <C> or pick edit Cc's from the Item menu. You will be shown a list of the mail 
message recipients. You can now add, delete, or edit recipients. When you are happy 
with the recipient list, press escape or pick Return to script from the Action menu.
Add CC 
Delete CC 
Edit CC 
Return To Script 



Edit Item  
This option will allow you to edit the script item highlighted. Just press <cr> or pick Edit 
from the Item menu.
If the item is a say, comment or mail message, the contents of the message are copied 
to a temporary file and your editor is invoked to allow you to make any changes you 
want. When you leave the editor, the original message text is replaced with the new 
contents of the temporary file.
If the item is a user command, you will be presented with each command parameter in a 
dialog box one at a time and you can make any changes required.

 
View Item 
Delete Item 
Defer/Undefer Item 
Edit Script File 



Edit Script File  
This option will allow you to edit the current script file (main, deferrals, automatic 
deferrals or history).
The entire script file is passed, unchanged, to your editor. Only use this feature if you are 
entirely familiar with the structure of your script file.
Edit Item 
View Script File 
Selecting Script Files 
Editor 



Editor  
This configuration option will allow you to specify the text editor to use when editing your
messages.
A dialog box will appear with the current setting and you can make any changes 
required. If your editor is not on the path, enter the full path. If it is a batch file, enter the
.bat extension.
Setup 



Exit Review  
This option will exit Review and return you to the point at which Review was invoked. If 
Review was invoked as part of the connection to the host, you will return to WigWam 
without connecting.
Connect To Host 



Exit on connection  
Only turn this option on if you are running WReview from TelePathy. Otherwise it will exit 
to DOS whenever you try to connect to the service.



Fcomment  
This command will add the text of the original message to the end of a comment (a 
confirmation is requested before any action is taken). 
Comment 
Comment Number 



Free Disk Space  

 
This command will display the free disk space on all your fixed disks.
To select this command press Alt-S or pick free disk Space from the Options menu.



History  
Toggles the use of the History file on and off.



History File  
The history file keeps a record of the script file contents for each attempted host 
connection. This is a new feature and will be improved upon if I get some useful 
feedback.
To switch to the history file, press <H> or select switch to History file from the File menu.
In adition to the normal script file entries, each host connection is prefixed by a header 
indicating the date and time of the connection.
You can perform the normal Review functions on all items except the headers. Headers 
can only be viewed or deleted. When a header is deleted, all items for that connection 
are removed from the history file.
Delete Item 
Defer/Undefer Item 
Selecting Script Files 



Mail  
A mail script item is denoted by 'mail to' appearing at the start of the first column of 
Review's script file list. The mail message recipient is given together with the subject. 
There may be other recipients or cc's, but these are not shown.
You can perform a variety of operations on a mail message by highlighting it and 
selecting the required operation from the Item menu (or pressing the appropriate hot-
key).
In addition to the normal script item functions, you can edit the recipient list by pressing 
<C> or selecting edit Cc's from the Item menu. 
Reply 
Edit Item 
View Item 
Delete Item 
Defer/Undefer Item 



Main File  
The main file is otherwise known as REPLY.BSC and contains all the instructions that will 
be sent to the Host system.
To switch to the main, press <T> or select Switch to main file from the File menu.
Selecting Script Files 



Prune History File  
This command will prune old connection information from Review's history file.
To select this command, press <Alt-P> or pick Prune history file from the Options menu. 
Review will prompt you for a date from which to keep connection information. It will also 
ask if you want to keep all mail.
History File 
Selecting Script Files 



Quiet connection  
If you don't want Review to pop up everytime you do a connection then turn this on.    If 
you want to check your replies (default) before you connect then have this off.



Remove Duplicate Commands  
Remove duplicate commands help information.This feature will remove duplicate 
commands contained in your script file. If Review finds any duplicates, it denotes them 
with a star '*' at the very left hand side of it's script file list. 
Delete Item 
Delete All Items 
Defer/Undefer Item 
Restore Original Files 



Reply  
A reply to a mail message is denoted by 'reply to' appearing at the start of the first 
column of Review's script file list. The reply recipient is given together with the subject. 
There may be other recipients or cc's, but these are not shown. 
You can perform a variety of operations on a reply by highlighting it and selecting the 
required operation from the Item menu (or pressing the appropriate hot-key). In addition 
to the normal script item functions, you can edit the recipient list by pressing <C> or 
selecting edit Cc's from the Item menu. 
Mail 
Edit Item 
View Item 
Delete Item 
Defer/Undefer Item 
Edit CC's 
View Original 
Fcomment 



Restore Original Files  
This option will restore all four script files (main, deferrals, automatic deferrals and 
history) to the state they were in when Review was invoked. 
If you make a real mess of your Review session, you can recover with this command.



Return To Script  
When you have finished editing the mail message recipients, this option will return you 
to the script file display.
Press <esc> or pick Return to script from the action menu.



Say  
A say is denoted by 'say' at the start of the second column of Review's script file list. This
is followed by part of the first line of your message. The first column shows the 
conference/topic where your message will be posted. 
You can perform a variety of operations on a say by highlighting it and selecting the 
required operation from the Item menu (or pressing the appropriate hot-key).
Edit Item 
View Item 
Delete Item 
Defer/Undefer Item 



Show All Titles  
This command will add the first line of the original message to Review's script file list for 
all the thread and delete commands. This command only applies to CompuServe 
installations.
To select this command, press <Alt-W> or pick shoW all titles from the File menu. 
Show Title 



Show Title  
This command will add the first line of the original message to Review's script file list for 
thread and delete commands. This command only applies to CompuServe installations. 
To select this command, press <W> or pick shoW title from the Item menu.
Show All Titles 



Selecting Script Files  
There are four script files:
main - messages and commands that will be posted when you connect
deferrals - messages and commands that have been manually deferred
history - record of the contents of main file for previous connections
auto deferrals - messages and commands that have been automatically deferred
When you invoke Review, you will always be placed in the main script file. 
To switch between the the main and deferrals files, press <S>.
To switch between the the main and history files, press <H>.
To switch between the the main and automatic deferrals files, press <M>.
Alternatively, pick the appropriate file selection item from the File menu. 
Deferrals File 
History File 



Thread  
This type of script item only applies to CompuServe and is denoted by a 't' at the start of 
the second column of Review's script file list. This is followed by the number of the 
message heading the thread to be downloaded and part of the first line of that message. 
The first column shows the forum containing the thread requested. 
You can perform a variety of operations on this type of item by highlighting it and 
selecting the required operation from the Item menu (or pressing the appropriate hot-
key).
View Item 
Delete Item 
Defer/Undefer Item 
View Original 



Time Out  
This configuration item determines the duration of the Review time out feature. If Review
is invoked as part of a host connection, it will proceed to the connection if you take no 
action within the period specified.
Enter the number of seconds you require. Zero will turn the time out feature off.
Setup 



Tool Bar  
Toggles display of the Tool Bar on and off.



Undefer All Items  
This option will undefer all items in the deferrals script file. Each item will be transferred 
to the main script file.
To select this option, press Alt-U or pick Undefer all items from the File menu. 
Defer/Undefer Item 
Defer All Items 
Defer/Undefer All Commands 
Selecting Script Files 



View Item  

 
This option will allow you to view the highlighted script item. If the item is a message, 
the message text is displayed. Commands are shown exactly as they appear in the script
file.
To select this option, press <V> or pick View from the Item menu.
View Original 
View Script File 



View Original  
This option will allow you to view the original message for highlighted comments (and 
CIS thread and delete commands). Review will scan the message file for the correct 
message and show it on the screen.
To select this option, press <I> or pick view orIginal from the Item menu.
View Original 
View Script File 
Comment Number 
Fcomment 



View Script File  
This option will allow you to view the current script file (main, deferrals, automatic 
deferrals or history). 
The entire script file is passed to the viewer. You can use this to see the file exactly as it 
is stored.
View Item 
Edit Script File 
Selecting Script Files 



Show - Script command  
The Show command provides you with three summaries of conference status:
Show New - lists the topics containing unread messages, and the number of new 
messages in each.
Show Joined - lists all the conferences you are joined to. For each conference Show Joined
lists the topics, together with a count of the total number of messages in the topic and a 
count of the new messages in the topic.
Show All - lists all conferences known to WW. This includes the ones you are joined to and
the ones you are not joined to.



Mailful - Script command  
Use this command to upload a file to your private mail directory. You will be prompted for
the name of the file to upload.



Rjoin - Script command  
Use this command to join a conference on the Host and start downloading messages 
from it. You will be prompted for the name of the conference. The menu command 
Conference/Join Remote (ctrl-Y) provides a friendlier interface and allows you to select 
conferences from a list.



Maildel - Script command  
Use this file to erase all your read mail from the Host. Any unread mail (mail which has 
not been downloaded to WW) will be unaffected.



Rresign - Script command  
Use this command to resign from a conference on the Host stop any messages from it 
being downloaded. Use the resign command to resign from a conference 'locally' on WW 
and allow other local WW users to continue participating in it.
When using rresign, you will be prompted to enter the conference to resign from. You can
specify a topic as well, in which case you will only be resigned from the specified topic 
and can continue to participate in the remaining topics.



Fdl - Script command  
Use this command to download files from the Host. To use it, you must first join the WW 
copy of the conference/topic containing the desired file. Then select the command and 
you will be prompted for the name of the file.
The menu command Conference/Download (ctrl-Q) provides a friendlier interface and 
allows you to select conferences from a list.



Rshow - Script command  
Use this command to execute a 'show' command on the host and file the result on your 
machine. You will first be prompted for the type of show: 'All' will list all conferences, 
'new' will list unread messages, 'joined' will list the conferences on the Host that you are 
joined to, and specifying a conference name will list the conference note. You will then be
asked for the name of the file on your machine to which the results should be 
downloaded.



Rresume - Script command  
Use this command to download the resume of a participant on the Host. You will be 
prompted for the person's nickname and for the name of the file on your machjine to 
which the resume should be downloaded.



Withdraw - Script command  
Use this command to withdraw a message on the Host. You can use the command to 
withdraw a message that you wrote, or, if you are a moderator of the conference, a 
message that someone else wrote. The last displayed message in the current conference
will be withdrawn, or, in Browse, the currently highlighted message.



Ful - Script command  
Use this command to upload a file to the host. To use it, first join the WW copy of the 
conference/topic you wish to upload to. The select the command and specify the 
pathname of the file to upload.



Getresume - Script command  
This command will download a copy of your resume for editing. You will be prompted for 
the name of the file in your local system to download to. When you have finished editing,
use the putresume command to upload the file.



Putresume - Script command  
Use this command to replace your resume on the Host with the text from a file on your 
system. You will be prompted for the name of the file to upload.



Getprofile - Script command  
Use this command to obtain a copy of your profile from the Host. You will be prompted 
for the name of a file on your local system for the profile to be downloaded to. After 
editing, you can use 'putprofile' to upload the modified version.



Putprofile - Script command  
Use this command to upload a modified profile to your Host. You will be prompted for the 
name of the file to upload. Use this command with care: the wrong profile may render 
your Host inaccessible!



Fdir - Script command  
Use this command to obtain a 'moderators directory' of files in a conference/topic. The 
'moderators directory' lists all files, whether they have been made publicly available or 
not. To use it, first join the conference/topic for which you require the list and then select 
the command. You will be prompted for the name of the file on your local system to 
which the list should be downloaded.



Getflist - Script command  
Use this command to obtain the moderator's file list in a form suitable for editing. To use 
it, first join the conference.topic for which you require the list and then select the 
command. You will be prompted for the name of the file on your local system to which 
the list should be downloaded. After editing it may be uploaded by 'putflist'.



Putflist - Script command  
Use this command to upload a modified moderator's file list. To use the command, first 
join the conference/topic which you wish to modify, and then select the command. You 
will be prompted for the name of the file to upload.



Binmail - Script command  
Use this command to binmail a file to a participant on the Host. You must first upload the 
file to your private mail directory, using 'mailful' or by some other means. Then select 
this command: you will be prompted for the name of the participant and the name of the 
file.



Maildir - Script command  
Use this command to obtain a list of all files in your private mail directory on the Host. 
You will be prompted for the name of the file on your local system to which the list should
be downloaded.



Mailfdl - Script command  
Use this command to download a file from your private mail directory on the host. You 
will be prompted for the name of the file to download.



Mailera - Script command  
Use this command to erase a file from your private mail directory on the host. You will be 
prompted for the name of the file.



Flist - Script command  
Use this command to obtain a list of files from your Host. To use it, first join the 
conference/topic that you wish to obtain the list for. Then select the command and 
specify the name of the file on your local system to which the list should be downloaded.



Restore - Script command  
This command will reset your message pointers on CIX to where they were at midnight 
(or when you last did a store) whichever happens to be nearest.
NOTE: It is only supported on CIX.



Scputdown - Script command  
Rebuild your message pointers from your local message base. Note this can take some 
time.



Fal - Script command  
Look at the list of files in the common types of archive files. .ZIP, .ARC are supported, as 
are some others.



Mailren - Script command  
This command lets you rename a file in your private mail directory.



Export - Script command  
This command lets you export a file from your private mail directory to the filepool. So 
that it may be placed in any flist.



Clearmail - Script command  
This clears your mail basket of all read mail on CIX. You will still have a copy on your local
machine though.



Mailunread - Script command  
This command allows you to mark a mail message as unread - and will automatically be 
downloaded after the next blink.



Absence - Script command  
With this command you can inform people that you won't be on CIX from a certain date 
to another. Note that all mail will be rejected if you use this command - and if the mail 
sender does not notice this while blinking they will assume you got the mail, when in fact
you didn't.



Copy - Script command  
You can copy a message from one conference/topic to another. See auction/items for 
what I mean.



Ffind - Script command  
Some kind of search command.



Rsquick - Script command  
Some kind of quick search command.



Rsearch - Script command  
Some kind of search command.



Rfind - Script command  
Some kind of search command.



Messages - Script command  
Allows you to get old messages from a conference on CIX. Remember to run addconw on 
the file afterwards - otherwise you won't see the messages appear in your message 
base.



Scputup - Script command  
This command uploads a file to CIX and executes the commands. Definitely not for the 
faint hearted - definitely not recommended.



Modera - Script command  
If you are the moderator of a conference then you can delete files from its topics. This is 
the command to do it with.



Modren - Script command  
Another moderator only function. You can rename files in topics, note that files with 
funny characters in them sometimes won't be renamed - in which case mail cixadmin or 
mat to do it for you.



Fexport - Script command  
This command exports a file from a conference to the filepool. Not to be confused with 
'export'.



Usenet - Script command  
This command allows you to collect your unread UseNet messages from CIX. To use it 
you must have mwhite's excellent usn2tp utilitiesinstalled along with WReview.



Urjoin - Script command  
This command lets you join a newsgroup on usenet. Note that you will have to modify 
your ACCEPT.USN file to contain the new newsgroup, otherwise it will be rejected. See 
the documentation with Usn2Tp on how to do that.



Urresign - Script command  
This command lets you resign a newsgroup on usenet. Note that you should modify your 
ACCEPT.USN file and remove the newsgroup. But it doesn't really matter if you don't.



Billing - Script command  
This command collects the billing from CIX.






